Chercher la dernière valeur d’une colonne ou d’une ligne dans Google Sheet

Depuis que je suis passé sur Chromebook, j’ai complètement abandonné la suite Office de Microsoft et donc Excel. Mais dans mon travail, le tableur n’est pas accessoire, je travaille les chiffres toute la journée et sans tableur ma tâche serait vraiment fastidieuse.

Sous ChromeOS, nous avons la chance de pouvoir choisir son logiciel de traitement de données. Avec Crostini nous pouvons utiliser LibreOffice, avec Chrome ou Android nous pouvons utiliser Excel online, mais le plus intégré à nos Chromebook reste Google Sheet.

A plusieur reprises, je vous ai dit comment assembler et désassembler une chaîne de caractères ou encore concaténer des éléments et même comment faire une liste déroulant conditionnelle. Aujourd’hui je vais vous expliquer comment trouver la dernière valeur présente dans une colonne ou une ligne d’un tableau Google Sheet.

La fonction Recherche pour trouver une valeur dans un tableau Google Sheet

Pour cette astuce j’aurais évidemment pu passer par un script, mais je voulais rendre la fonction accessible au plus grand nombre et j’ai donc détourné la fonction RECHERCHEV() ou RECHERCHEH() pour trouver la dernière valeur d’un tableau.

Comme se construit la fonction RechercheV()

La fonction RECHERCHEV(), est une recherche verticale. elle permet de chercher une clé dans la première colonne d’une plage et affiche la valeur d’une cellule spécifiée dans la ligne trouvée.

Elle se construit de la manière suivante :

=RECHERCHEV(Clé de la recherche; plage de la recherche; index de la colonne ou chercher; affiche la valeur exact ou non de la recherche)

Vous allez me dire ,et vous n’auriez pas tort, que cette fonction recherche une valeur précise en fonction d’une condition. Alors comment peut-elle trouver la dernière valeur d’une colonne ?

La réponse est d’une simplicité à toute épreuve. Ce qui est important à savoir dans cette fonction, c’est qu’elle fait une recherche en colonne de haut en bas et si la fonction ne trouve pas le résultat, elle renvoie par défaut la dernière valeur lue, donc la dernière de la colonne.

Voilà vous savez tout. Il suffit donc de donner une clé de recherche que la fonction ne pourra pas trouver dans votre tableau, un nombre tellement grand qu’il ne sera jamais présent. Dans mon exemple j’utilise simplement la valeur 9^9, ce qui donne le nombre 387420489

Comment construire notre fonction de recherche

Pour chercher notre dernière valeur présentée dans la colonne,  voici comment je décompose ma fonction :

  • nous allons tout simplement lui donner la clé de recherche avec la valeur 9^9
  • puis nous lui indiquons la plage de recherche, dans notre cas B2:B25
  • enfin je veux chercher ma valeur uniquement dans la colonne B donc je lui indique la valeur “1” qui représente ma seule colonne de recherche.

Le résultat est le suivant:

=RECHERCHEV(9^9;B2:B25;1)

RechercheV() pour trouver une valeur dans Google Sheet

Nous pouvons chercher la dernière valeur d’une ligne pour cela il suffit de remplacer la fonction RECHERCHEV() par la fonction RECHERCHEH() qui est construit exactement de la même façon.

Vous l’aurez compris, ces deux fonctions n’ont donc pas été développées pour une telle recherche. Mais savoir détourner les choses permet souvent de ne pas avoir à réinventer la roue à chaque fois.

Aviez-vous pensé à utiliser les fonctions RechercheV et H pour faire une telle recherche ? Donnez-moi votre avis, posez-moi vos questions dans la suite de cet article à travers vos commentaires.

Si vous avez trouvé une faute d’orthographe, informez-nous en sélectionnant le texte en question et en appuyant sur Ctrl + Entrée s’il vous plaît.

12 réflexions au sujet de « Chercher la dernière valeur d’une colonne ou d’une ligne dans Google Sheet »

  1. Comme promis, voici deux vidéos Youtube de démonstration.

    Afficher la DERNIÈRE VALEUR d’une COLONNE par des formules – Vidéo 1

    Afficher la DERNIÈRE VALEUR d’une LIGNE avec des formules – Vidéo 2

    @Nicolas,
    si tu veux en savoir plus sur les formules, va voir dans mon groupe d’aide,

     » Bienvenue dans le groupe d’entraide des applications Google Drive Fr, Gmail et Chromebook  » > https://groups.google.com/forum/#!forum/gdrivefr-gmail-chromebook

    Le document en lien partagé n’est accessible que pour les abonnés du groupe.

    Bonne semaine.

  2. Bonjour,

    Et voilà la version texte de recherche de la dernière valeur d’une colonne :

    =RECHERCHEV(« Z »;B2:B25;1)

  3. Bonjour @Nicolas,
    je viens d’essayer la recherche de la dernière valeur d’une ligne, mais ça ne fonctionne pas .
    Je viens de vérifier sur une colonne ayant des valeurs mélangées (dates, mots, chiffres), puis sur une ligne mélangée.

    Sur une colonne, cela renvoie l’erreur #N/A SI la dernière valeur est un MOT
    Valeur « 387420489 » introuvable lors de l’évaluation de VLOOKUP.

    Idem pour une ligne avec =HLOOKUP(9^9;2:2;2), cela renvoie l’erreur #REF!
    HLOOKUP a pour résultat une valeur hors plage.

    A priori cela ne fonctionne que sur des colonnes ou lignes de dates ou nombres ..
    Donc, il faut tout de même arriver au script pour n’importe quelle valeur !

    As-tu testé aussi sur n’importe quelles valeurs dans une colonne ou ligne ?

    Bon 1er mai 🙂

    1. Effectivement c’est fonctionne n’es opérationnelle que pour la recherche de nombre, chiffre .. pour les lettre il suffit de changer la veleur de recherche par un texte qui ne pourra pas être reconnu

    1. J’ai galéré avec des script avant de me poser la bonne question et trouver cette solution. Je ne pense pas que la fonction RechercheV() est été penser comme cela, mais cela ne fait pas de mal de détourner les fonction

      1. @Nicolas,
        En faisant beaucoup de tests, j’ai trouvé comment faire pour afficher les dernières valeurs quelles qu’elles soient, sur colonnes ou sur lignes.
        Cela demande beaucoup de formules mais c’est faisable.
        8 formules pour rechercheS sur ongletS et leurs ColonneS
        et 8 formules pour rechercheS sur ongletS et leurs LigneS .

        J’ai ajouté un onglet supplémentaire nommé « Der VAL » à mon spreadsheet pour pouvoir effectuer une recherche sur n’importe quel onglet, n’importe quelle ligne et n’importe quelle colonne et ce pour n’importe quelles valeurs …

        Je vais essayer demain de faire une vidéo pour montrer comme c’est bien pratique pour effectuer x recherches via x onglets et ce pour x valeurs sur lignes ou colonnes 🙂

  4. Super article !
    Au boulot, je n’ai accès qu’à Excel et je me suis mis au macro et tout et tout, c’est vraiment ce qui me manque avec sheets et j’avoue que c’est moins intuitif pour moi les scripts. Va falloir que je bosse un peu plus le sujet …

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.